Jump to content
Forums Gone... but not forgotten!

Tired of these Ads? Register Today!

  • Welcome to Forever Pontiac

    We are a community of Pontiac enthusiasts. The purpose of our community is to keep alive the Pontiac spirit by sharing (or showing off) our cars, discussing Pontiac, helping each other work on our cars and find information, plus attend various meets/shows/etc... To aid discussion, sharing, event planning and selling of parts/cars/anything, we have various parts of the website to aid this from Forums to an online Garage to Classifieds to even a Document Download Repository. You can find links to these in our navigation above based on what each section helps with (discussion, local events, learning, etc...).

    We invite you to contribute, find help or just view some of our member's amazing cars! Don't forget, we also have great contests from time to time (like our Pontiac of the Month and yearly calendar contest) and our Pontiac This OR That, a fun game where you choose the best of two randomly selected Pontiacs from our online garage.

    We look forward to seeing you around!

  • 0
QueenCognac

02 GP 3.1L Temperature guage fluctuating

Question

Anyone able to tell me if this issue is a thermostat or the sensor? My 02 GP 3.1l temp guage started fluctuating a lot and heat would work then not work...after 2 days now the heat is completely gone amd guage is still fluctuating? Any ideas as im stuck fixing this myself. [emoji19]

Sent from my LGMS330 using Tapatalk

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Have you checked the coolant level? Not sure if you have the plastic waterpump elbows on that one.i did and they cracked and leaked.

Share this post


Link to post
Share on other sites

Tired of these Ads? Register Today!

  • 0

It's not that simple to answer without being there. Many things and multiple things can be involved. That said, with it being a 02 I’ll assume the antifreeze has been changed seldom. If it's never been flushed and if most or all of its life there's been Dex Cool in the system you most likely have major blockage. If that's the case it will require a complete redo of the coolant system. Water pump, lines, heater core and radiator. What you described makes me lean towards that. So you will need to verify that condition before you start down that road.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Tired of these Ads? Purchase Enhanced Membership today to remove them!
×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.