Jump to content
Forums Gone... but not forgotten!
  • Welcome!

    Welcome to Forever Pontiac, where we keep the memory of Pontiac alive with great discussion, maintenance tips, restoration/modification progression "blogs" and help from professional & DIY mechanics. Also, wonderful competitions that occur regularly. Please register for an absolutely free account to join in!

1 Screenshot

About This File

2005 Pontiac GTO Owner's Manual


User Feedback

You may only provide a review once you have downloaded the file.

There are no reviews to display.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Peppergreengto
      Three years ago my son and I drove to Nebraska to buy my first GTO. I was specifically looking for a 70-72, green project that wasn’t going to break the bank. We had a great time. The car turned out to be more work than I anticipated but it’s getting closer to paint and may see the road this year. When I get done more time I’ll start a build thread. I have tons of pictures on my Instagram page also. I use the same name on Instagram. 

    • By 1967GTO-NC
      Hi there,
      Just introducing myself as a new member. I have attached a picture of my 1967 GTO just after picking it up from the paint and body shop where I had the new paint done. I bought this car when I was 16 off the showroom floor. I wanted something different than the Mustangs and Chevelles that everyone else had. This GTO was it. Still love to get out and drive it although I don't drive it as much as I did in the early years. 
      That's the short story. Look forward to hearing from others.

    • By Jcro
      Hi I’m new here, I’ve been sitting parking on a 1974 Pontiac GTO for about a year. I got it running for the first time in about six months yesterday after I rebuilt my carbs. I have two Holley 600 on a tunnel ram intake. I also replaced my point distributor with an HEI. The engine I have in the car is a 1975 firebird 400. The issue I’m running into is the car idles great but when I give it about half throttle it bogs down and stumbles like it’s gonna die but when I take my foot off the gas it reeves back up to the proper RPM and idles fine. Any advise? I assume it’s something amiss with my ignition system or my carbs. 
    • By MaggieG
      This morning, I drove about 3 miles. Put it in park but left it on. Went to leave, put it in drive... and nothing... it will reverse and will also use Tapshift (manual). Also with Tapshift it will go though all the gears. But it won't move or do anything (except rev the engine) in DRIVE. What is wrong?! 
    • By Sweet Broccoli
      Hey!
      I just noticed this loose-feeling wire and electrical connector on my 71 Lemans, and I don't know what component it goes to. It's on the passenger side under the hood, right in front of the wipers. 
      My windshield washer isn't working atm, so I'm thinking this could have something to do with that. 
       
      Thanks for any help!

Tired of these Ads? Purchase Enhanced Membership today to remove them!
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.