Jump to content
Forums Gone... but not forgotten!
Pontiac of the Month

JAH11's 1968 GTO

2024 June
of the Month

  • Rev up your passion for Pontiacs and join our vibrant community of enthusiasts!

    Whether you're a die-hard fan of classic muscle cars or you've got a soft spot for sleek modern models, you've found your home here at Forever Pontiac. Our community is dedicated to celebrating everything Pontiac, from the iconic GTO to the legendary Firebird and everything in between.

    Unlock access to expert advice, stunning photo galleries, engaging discussions, exclusive events, and more!

    Start your Pontiac journey with us today!

    Sign up now! 🏁

Generator light on and burning up regulators


Recommended Posts

I have installed an HEI distributor and followed the install instructions, now I have a generator light on and I’m burning up my external regulator, I have no loose grounds. I have read on several forums several different opinions on what to do when installing one, so I’m looking for a solid answer on what to do. It’s a 1968 Pontiac Lemans with a factory 350 HO, manual transmission. 

Link to comment
Share on other sites

Tired of these Ads? Register Today!

I have an HEI on my '63 Catalina but at the same time I put on a later 100 amp alternator because I also installed an A/C and the stock 35 amp would not carry everything. The new alternator has an internal regulator and has worked flawlessly. The questions I would ask are:

Where did you tie in your positive to the new distributor? Did it have points in the distributor, if so the coil was fed through a resistant circuit to keep the coil voltage under 9 volts. If you are tied in downstream of the resistor or resistant wire it could conceivably cause a problem. go back and tie into the ignition circuit at the ignition switch, make sure you are in the Ign wire and not the assessory circuit.

If you are already wired in that way then I can think  of three possibilities to solve the problem. One would be to install an alternator with the internal regulator, they are not that expensive on ebay. you connect all the factory wires and connect the external regulator wires together and toss the old regulator.

second would be to try a diode or a relay in the feed wire to the distributor to isolate the distributor from the ign circuit. I can not figure out any reason why it should cause problems with the regulator but since you apparently did not do any other changes it pretty much has to be something in the HEI causing the problem.

third the 70's and possibly 80's vintage Mopars used an external electronic regulator. they will work with a delco alternator. I used to use them on boats when the engine vibration would drive the point type regulator crazy. It has been so long since I have done that I can not tell you which of the two wires is the positive and which goes to the alternator but you can probably find that information on the internet somewhere.

good luck

 

 

Link to comment
Share on other sites

  • 10 months later...

The fix to this is adding a diode to L wire on your regulator to prevent the back feeding. The 10 DN alternator is so weak, even better is a 10 SI or even better a cs130.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Tired of these Ads? Purchase Enhanced Membership today to remove them!
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.