Jump to content
Forums Gone... but not forgotten!
Pontiac of the Month

4 bucket 67's 1967 GTO

2019 March
of the Month

  • Welcome to Forever Pontiac

    We are a community of Pontiac enthusiasts. The purpose of our community is to keep alive the Pontiac spirit by sharing (or showing off) our cars, discussing Pontiac, helping each other work on our cars and find information, plus attend various meets/shows/etc... To aid discussion, sharing, event planning and selling of parts/cars/anything, we have various parts of the website to aid this from Forums to an online Garage to Classifieds to even a Document Download Repository. You can find links to these in our navigation above based on what each section helps with (discussion, local events, learning, etc...).

    We invite you to contribute, find help or just view some of our member's amazing cars! Don't forget, we also have great contests from time to time (like our Pontiac of the Month and yearly calendar contest) and our Pontiac This OR That, a fun game where you choose the best of two randomly selected Pontiacs from our online garage.

    We look forward to seeing you around!

  • 0
Nrodman95

Can anyone help me PLEASE??

Question

Hi guys I'm new here, I'm having a problem with my G6, it has the 3.5l v6 in it. Today it started smoking white from the exaust and you can smell oil burning bad. I think my buddy over filled it, could that cause it to smoke white? It does have 285,xxx miles on it.... Also have a oil leak coming from somewhere around the oil filter but can't seem to find it either. Any help would be much appreciated. Thanks in advance.

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Need help figuring out why my 07 G6 3.5l v6 started smoking from the exaust  yesterday! It's my only ride and I don't have the money for a new car... Kinda freaking out lol. It's smoking white and you can smell oil burning bad, my buddy accidently over filled the oil. Not sure if that would do it or not. It doesn't get hot at all and been having TEERIBLE gas milage. And also have a oil leak somewhere around the oil filter but can't seem to find it. Any help is appreciated. Thanks in advance.

Share this post


Link to post
Share on other sites

Tired of these Ads? Register Today!

  • 0

Find someone to check the oil filter for you. Sometimes the seal doesn't sit/fit properly and can cause your leak problem. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


Tired of these Ads? Purchase Enhanced Membership today to remove them!
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.