Jump to content
Forums Gone... but not forgotten!
Pontiac of the Month

Steve Morris' 1967 GTO

2021 April
of the Month

  • Welcome!

    Welcome to Forever Pontiac, where we keep the memory of Pontiac alive with great discussion, maintenance tips, restoration/modification progression "blogs" and help from professional & DIY mechanics. Also, wonderful competitions that occur regularly. Please register for an absolutely free account to join in!

Transmission Filter install Mistake ?


Recommended Posts

Hey there

I installed new gasket and filter for TH400,
when I fitted the bolt that holds the new filter on the filter was still “loose” , so I added some washers so the filter didn’t move about. 
It was a while between pulling the pan and reinstalling. 
Now I have a bad feeling the washers shouldn’t be there.  
Is this a re do or will it work ok. 
just asking to be safe than sorry 

cheers Doug. 
 

Link to post
Share on other sites
  • 7 months later...

Tired of these Ads? Register Today!

I would recheck it. Its pretty common for the old rubber ring that goes on the filter to get stuck in the transmission and not be noticed, and then when the new is applied you have 2. For the brief time it takes to look, I would. Transmission rebuilds are not cheap.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Tired of these Ads? Purchase Enhanced Membership today to remove them!
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.