Jump to content
Forums Gone... but not forgotten!

462goat

New Members
  • Content Count

    4
  • Joined

  • Last visited

Community Reputation

5 Neutral

About 462goat

  • Rank
    Fresh Meat
  1. Frosty, The front parking brake cable is in, it wasn't too bad to get it in but I wouldn't want to do it again. The only problem I had is with the center cable, it was too short. what I found out was in 1967 if you had the M40 transmission the front cable was longer than that of the 350 or manual trans. the cable I had was 90" too short, so put in new front cable and ordered the center cable to go with it (105") that was too long. So I had one made up it was 101" and now everything is working perfect. What transmission does your '67 have ? And did you have any issues with your c
  2. Thanks for the reply Frosty, have my wire strung, cable should be here Fri. I did get lucky in the brake dept. this car came with factory front disc brakes. 🙂
  3. Frosty , thanks for the info, just got the cable out now waiting for the new cable to arrive. Really strange that this car has had 5 different transmissions and no one changed the original front cable, this car came from the factory with the M40 trans. Thanks again so much 👍
  4. Need to replace the front parking brake cable on my '67 gto . Anyone know where I can get or download instructions on how to do this , service manuals are of no help.
Tired of these Ads? Purchase Enhanced Membership today to remove them!
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.