Jump to content
Forums Gone... but not forgotten!

Tired of these Ads? Register Today!

bigcat73

Members
  • Content Count

    3
  • Avg. Content Per Day

    0
  • Joined

  • Last visited

Community Reputation

0 Neutral

About bigcat73

  • Rank
    Fresh Meat

Profile Information

  • Location
    PA
  • Interests
    American steel

Forever Pontiac

  • Name
    Lucas H
  • Gender
    Male
  • Year
    1973
  • Car
    Catalina
  • Trim
    2dr
  • Engine
    400 V8 2bbl
  • Style
    Coupe
  • Color
    green

Recent Profile Visitors

98 profile views
  1. Hi guys. My 73 Catalina has a 400 motor with 2bbl and th375 trans. The th375 won’t shift out of 1st. From my understanding it’s nearly identical on the inside and outside to a th400 but uses a th350 tail shaft , 27 spline output shaft instead of 32, and a different yoke (th350)? If I buy a BOP TH400 can I just pull the tail shaft of my th375 and put it on the th400 for a direct replacement? Thanks for the help
  2. bigcat73

    73 Catalina runs poorly

    Thanks for the suggestions guys. Had it running good for a little. Need to check out timing more.
  3. Hi. I am Lucas. I have a '73 catalina 2dr with 400 motor, 2gc carb, th375 trans. Car has 72,xxx on it. Car is pretty original but previous owner decided to spray the roof white. When buying the car I noticed the car had a new starter, fuel pump, fuel lines, looked like the ignition had been gone through (however still points), and he had told me the tank has been cleaned. I believed him because it fired up on the first crank. I bought it and took it home. Put on buick rallye's and fresh tires when I noticed the water pump started to leak. Replaced it and the radiator hoses and went on. Drove the car very regularly with very few issues when one day I drove it to school and simply didn't want to fire. Had to have it towed home. Tested the fuel pump and it was getting fuel to the carb. The plugs were sparking too. So I had the carb rebuilt. Now it runs but over half throttle or so it will stumble very bad when trying to return to idle. I rev it up a bit and will bump up to a higher idle that doesn't sound right. I tested for vacuum leaks around carb and found none. Any ideas?
  4. Hi. I am Lucas. I have a '73 catalina 2dr with 400 motor, 2gc carb, th375 trans. Car has 72,xxx on it. Car is pretty original but previous owner decided to spray the roof white. When buying the car I noticed the car had a new starter, fuel pump, fuel lines, looked like the ignition had been gone through (however still points), and he had told me the tank has been cleaned. I believed him because it fired up on the first crank. I bought it and took it home. Put on buick rallye's and fresh tires when I noticed the water pump started to leak. Replaced it and the radiator hoses and went on. Drove the car very regularly with very few issues when one day I drove it to school and simply didn't want to fire. Had to have it towed home. Tested the fuel pump and it was getting fuel to the carb. The plugs were sparking too. So I had the carb rebuilt. Now it runs but over half throttle or so it will stumble very bad when trying to return to idle. I rev it up a bit and will bump up to a higher idle that doesn't sound right. I tested for vacuum leaks around carb and found none. Any ideas?
Tired of these Ads? Purchase Enhanced Membership today to remove them!
×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.