Jump to content
Forums Gone... but not forgotten!
Pontiac of the Month

Michael Dalke's 1967 Firebird

2020 March
of the Month

  • Welcome!

    Welcome to Forever Pontiac, where we keep the memory of Pontiac alive with great discussion, maintenance tips, restoration/modification progression "blogs" and help from professional & DIY mechanics. Also, wonderful competitions that occur regularly. Please register for an absolutely free account to join in!

  • 0
Sign in to follow this  
gandhi_2006

possible pcm problems help!!

Question

i have a tech question for ya, about 2weeks ago i lost third gear. I dropped the pan and everything was clean no metal shavings fluid looked new. Now today after work I started my car and my DIC said "service abs, no traction control, no stability control, and no steering assist. I took it to Orilleys to have them scan the pcm. It said tcm read error, bcm read error, speed sensor error,and some others things. I get the feeling that my pcm is bad. It is a 04 grand prix gtp comp g with 75k miles. What are your thoughts folks. Thank you

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

My first thought would be to check your speed sensors and brake booster module and harnesses for moisture and/or corrision. Drying them out and applying some di-electric grease might help. Those would things certain impact the ABS/Stablitrak/traction control systems. Using compressed air to blow out any dirt from the connections is a good thing. You may have a faulty speed sensor on one of the wheels that may need replacing too. These Grand Prixes have had issues with this in the past. 


 


A poor or faulty ground is another possibity, but those can be a devil trying to find too. So check each wheel well, the brake booster, and ECM in the engine compartment for any loose, broken, or missing wires and connections.


Share this post


Link to post
Share on other sites
  • 0

Thank you frosty.  I did indeed unplug the the harness and cleaned them out and now it is intermintent, so i think the sensors may be loose or possibly bad. 


 


Also i ended up buying a new pcm from Will at Overkill and i must say I freaking love it.  The throttle response in amazing, engine stays much cooler,  a much better ride overall.  I definetly recomend this pcm.


Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.