Jump to content
Forums Gone... but not forgotten!
  • Welcome!

    Welcome to Forever Pontiac, where we keep the memory of Pontiac alive with great discussion, maintenance tips, restoration/modification progression "blogs" and help from professional & DIY mechanics. Also, wonderful competitions that occur regularly. Please register for an absolutely free account to join in!

  • 0

1971 pontiac lemans swap or rebuild


Question

I am wondering what i could do to my 1971 pontiac t-37 for more power. i am thinking about rebuilding the original 350 and upgrading it or looking for a 400 and putting that in.

Link to post
Share on other sites

1 answer to this question

Recommended Posts

Tired of these Ads? Register Today!

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Featured Topics

  • Similar Content

    • By 82firebird
      So I am replacing my engine which was originally 8305 was swap to a 350, but instead of having someone else rebuild it I was going to buy a new one put it in and learn how to rebuild the current 350 in my own spare time. My question is is An old350 Just an old 350 or is that your specific because of the mounting set up? Because I’m finding a lot of good set up’s four 1980 Chevy/Pontiac  and older. So can anybody point  Me to a direction that can tell me if my car is compatible with any other year of Chevy/ Pontiac years? 
    • By Jcro
      Hi I’m new here, I’ve been sitting parking on a 1974 Pontiac GTO for about a year. I got it running for the first time in about six months yesterday after I rebuilt my carbs. I have two Holley 600 on a tunnel ram intake. I also replaced my point distributor with an HEI. The engine I have in the car is a 1975 firebird 400. The issue I’m running into is the car idles great but when I give it about half throttle it bogs down and stumbles like it’s gonna die but when I take my foot off the gas it reeves back up to the proper RPM and idles fine. Any advise? I assume it’s something amiss with my ignition system or my carbs. 
    • By 65gtotrips
      My compilation of assorted Pontiac Muscle...
      PONTIAC • ALL YEARS • PHOTO ALBUM
      65GTOTRIPS https://foreverpontiac.com/profile/3605-65gtotrips/
    • By DrJones
      I need help figuring out why my 400 is overheating
      It is a 1987 gen3 Fire-bird Formula (reFormulated) with a 1971 Pontiac 400 block casting #481988 bored .030 over with Keith Black dish pistons, crank has been turned .020/.020. Rotating assembly has been balanced, Number 16 heads with new valves and springs, 72cc cambers. Howard's CAM in.482 ex.470, true dual exhaust, new water pump with cast impeller, divider plate clearance set as close as possible to impeller. New 4 core aluminum radiator with 2 10 inch electric fans pulling air and 2 12 inch electric fans pushing air. A/C condenser removed to allow maximum air flow. Removed thermostat, still overheating. Installed a flow restrictor hoping the water was flowing to fast through the radiator for efficient heat transfer. No still HOT. New 180 degree thermostat. With each change it continued to overheat, although the time it takes to overheat varied. I really hope someone here has an idea what I am facing.


    • By steveeoaktree
      Well fellas, I will finally have some more time Saturday to get to tweaking the issues with the '76 GP's idle/accel issues. Started with running terrible and popping back through the carb. After a new fuel pump (smelled fuel in the oil), wix inline filter and new lines, and 2 Rochester carb rebuilds (soaked the parts overnight in the carb solvent the 2nd time as well as installing a new brass float), re gapped the new plugs to .045 that were gapped at .080 by the seller, new vaccum lines, and I also have the new pcv valve and lines (there wasn't one) to install Sat. It now accelerates MUCH better, but idles like it wants to die at stoplights (and does die sometimes) but starts right back up. I thought maybe to tweak the vaccum lines to see how they work best b/c some diagrams show a "t" going to the vac advance with one going to the manifold, and the other going to the carb... and some diagrams just show a single line to the carb. I also don't know it the missing pcv would cause any minor idling or accelerating issues, but I do know that it should be there. the timing is solid. I am going to drain the tank again and refill it with 89 octane fuel to also see if that helps. I am curious though, as it seems to only try to die after it's warmed up. I know there is a choke internal in the intake but it's tough to find a diagram specific enough to list all of the line connections for a 1976 400 2bbl... (most show them for the 4 bbl) If any of y'all have any tips, I'll surely give them a try either tomorrow after work, or Saturday when I do the rest... Have interior pieces to dye inbetween as well so it should be a great Poncho day -- just would feel much better if I could get this baby to run smooth! She's sooo close...

       

      Thank y'all  for your time, and all of the guidance that you've given.

       

      Stevee

Tired of these Ads? Purchase Enhanced Membership today to remove them!
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.