Jump to content
Forums Gone... but not forgotten!
Pontiac of the Month

58Bonne's 1958 Bonneville

2019 June
of the Month

  • Welcome to Forever Pontiac

    We are a community of Pontiac enthusiasts. The purpose of our community is to keep alive the Pontiac spirit by sharing (or showing off) our cars, discussing Pontiac, helping each other work on our cars and find information, plus attend various meets/shows/etc... To aid discussion, sharing, event planning and selling of parts/cars/anything, we have various parts of the website to aid this from Forums to an online Garage to Classifieds to even a Document Download Repository. You can find links to these in our navigation above based on what each section helps with (discussion, local events, learning, etc...).

    We invite you to contribute, find help or just view some of our member's amazing cars! Don't forget, we also have great contests from time to time (like our Pontiac of the Month and yearly calendar contest) and our Pontiac This OR That, a fun game where you choose the best of two randomly selected Pontiacs from our online garage.

    We look forward to seeing you around!

Recommended Posts

So about 2 weeks ago I took the ol' girl in to have the new wheels and tires put on and they look great! Driving home from the tire shop I might have made it about a mile and a half and the trans gave up the ghost. I was told that changing the fluid and filter was most likely what caused it. So I barrowed a buddy's lift and took the motor and trans out figuring i'd replace and touch up a few things. I've since replaced the master cylinder, all wheel cylinders and all brake lines just needing to connect the lines to the MC tomorrow. I knew there were a few small holes in the passenger's side floor board, but I was way wrong and the seats are coming out to replace that floor pan. Along with the new floor pan I'll be making a new transmission tunnel and fabricating a new transmission crossmember. Not sure who did the original motor/trans swap but the trans was actually pushed up touching the floor right behind the bellhousing and while the trans is bolted to the mount the plate they welded to the brace allowed for the long tail shaft to sit right on top of the brace causing vibration at both spots. I did get the trans back and I'll be starting the floor pan and trans work in the next couple days.  I'll get pics in the next couple of days if I remember but here's one of the trash inside of the pan and 1 of the floor pan.

IMG_6826.JPG

IMG_6841.JPG

Share this post


Link to post
Share on other sites

Tired of these Ads? Register Today!

Actually looks like it had water in it. Changing the fluid will sometimes cause some concerns but not changing the fluid & filter will always cause problems. What year is the G/P ?? Why does it have a long tail in it. If you have the choice I'd replace the trans with the correct trans as you can end up with other concerns by having the wrong trans in the car.  Also if you drive it all the time & you aren't going back to 100% stock I'd install a 200r4 or a 700r4 tran sso you have an overdrive trans which will make long distance driving much easier on the engine, & it's just as easy to do & may even  be  cheaper.  How about some pics ??? 

Share this post


Link to post
Share on other sites

Yes it did have moisture in it, most likely from sitting 9yrs before I got it. Its a 63' Grand Prix with a 68' 428 and 400 turbo. The original trans looks to have been a "Slim Jim" and I'm happy with the 400 turbo and used to run them in a couple of old Chevy's and race cars years ago. Had the guys that did the engine/trans swap did things the correct way there wouldn't be any problems with this set up. Unfortunately people get cars and do things to them not having any clue as to what they are doing and we're left figuring out what they did, how they did it and how to fix it. That's where I'm at now. Guess if you buy a car already assembled and restored you wouldn't have these kinda problems, but what fun would that be lol. So I got the master cylinder hooked up now and spent a day and a half chasing down a leak that turned out to be a "top side" leak. There was no fluid dripping to find the leak and it turned out to be on the drivers side rear flare where it connected to the wheel cylinder. I've got the engine and trans back in the car now and the trans brace I found from another old 68' Pontiac that I just had to clean up and weld a tab onto for the mount to sit on. The drive shaft was extremely tight coming out, like just barely enough room to for the u-joint clear the rear end yoke. So I'll be cutting down the driveshaft a couple inches tomorrow after pulling an engine from a C10. Hopefully then I can drop the car off the lift and take it for a test ride.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


Tired of these Ads? Purchase Enhanced Membership today to remove them!
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.