Jump to content
Forums Gone... but not forgotten!
Pontiac of the Month

Shakercars's 1972 Trans Am

2019 August
of the Month

  • Welcome!

    Welcome to Forever Pontiac, full of great ideas for Pontiac performance, maintenance, or for peer-to-peer assistance from Professional and DIY mechanics. Also, compete in our Pontiac monthly competitions. Please register if you'd like to take part.

Recommended Posts

I’m having an issue where my GTO runs great in park. But when I put it in drive it idles much lower and stumbles like it’s going to stall and if I give it any gas it stalls out. This is my first classic and I’ve never worked with carbs until this car. So I’m assuming it’s a tuning issue. But I might have something hooked up wrong or possible vacuum issue but I sprayed the engine down with throttle cleaner and found no vacuum leaks. If you can see anything hooked up wrong or tell me what I should mess with it would be much appreciated 

image.jpg

Share this post


Link to post
Share on other sites

Tired of these Ads? Register Today!

Hiya,

Check the ‘Accelerator Pump’ on the carburetor(s)...that’ll cause your symptoms...

dave

Share this post


Link to post
Share on other sites

What size should I have in it 

Share this post


Link to post
Share on other sites
13 hours ago, Jcro said:

What size should I have in it 

 You don’t mention, in the other post, changing the vacuum secondary's of the carbs to port vacuum! Did you? If those are connected to manifold vacuum that’s a problem. 

In the picture you’ve taken I see more questions than answers. It doesn’t look like the secondary’s are connected to port vacuum. Also wow, all the adaptors connecting the carbs to the tunnel ram present a challenge! Are there vacuum leaks? Quite possible, that needs check at each gasket interface with ether. Any leaks at those will cause precisely what you describe. Are the gaskets at each interface the correct ones? If not that can change vacuum! 

I assume the car came with that setup on it and you did not install it?

Share this post


Link to post
Share on other sites

I don’t know what you mean by changing the vacuum secondary to ported vacuum I don’t believe I did how would I do that. I don’t see any kind of vaccine line going to the diaphram on the side of the carb and I sprayed down all of the adapters and intake and found no vacuum leaks. Yes this is the set up I bought it with 

Share this post


Link to post
Share on other sites
Posted (edited)
22 hours ago, Jcro said:

I don’t know what you mean by changing the vacuum secondary to ported vacuum I don’t believe I did how would I do that. I don’t see any kind of vaccine line going to the diaphram on the side of the carb and I sprayed down all of the adapters and intake and found no vacuum leaks. Yes this is the set up I bought it with 

It’s been quite a few years since I worked on vacuum secondary Holleys, I always preferred mechanical ones, but it appears your vacuum secondary’s are fed internally. I still suspect they are the culprit. As you will see or hear, in this video.

Go to You tube select search and paste this link into it. http://... http://www.jegs.com/p/Holley/Holley-Vacuum-Secondary-Components/757289/10002/-1 ------... that should bring up Jegs tutorial. This will explain how they work how to check them and what some issues might be.

Additionally, you may still have a vacuum leak! Carb cleaner is not the best fluid to use for finding a vacuum leak, ether is. 

When the engine is in an idle have you checked engine vacuum? What is the number. When you put it in gear what does the vacuum fall to? Have you checked compression? If it’s not vacuum There are a lot of things it could be! Spark plug wires, just bad carbs that need rebuilt, distributor issues, etc.

let us know how you make out, we’ll keep pecking away at this till you get it figured out!

Good luck!

Edited by Last Indian

Share this post


Link to post
Share on other sites

Why isn't your kick down cable connected. That has to be connected & adjusted correctly or your engine will stall as it controls the amount of vacuum & when your trans shifts. You need to have someone with the experience to help you or your going to burn up your trans if you haven't already.  

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Tired of these Ads? Purchase Enhanced Membership today to remove them!
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.