Jump to content
Forums Gone... but not forgotten!
Pontiac of the Month

58Bonne's 1958 Bonneville

2019 June
of the Month

  • 0
Dwayne Hoover

Odometer and trip meter

Question

My odometer and trip meter don’t work.  Any ideas or places that could fix this?  1986 TA, 305 v8.

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

This could be a number of causes and the fixes vary as well. The mechanical odometer and trip odometer are driven by a stepper motor off the same VSS buffer signal from the ECM that also drives the speedometer.

1. The flexible printed circuit board on the back of the instrument cluster may be loose or have missing or broken clips.

2. The stepper motor that drives the odometer(s) may have broken or missing teeth.

https://www.shapeways.com/product/KA6JCDSEX/third-gen-firebird-odometer-86-92-140mph-gear?li=shareProduct

3. The stepper motor may have failed completely.

 

 

Share this post


Link to post
Share on other sites

Tired of these Ads? Register Today!

  • 0

Thanks Frosty.  I can get a refurbished instrument cluster from Hawk Motorsports, but it is quite pricey and I’m not sure it will fix the problem.  Thanks again for the info!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


Tired of these Ads? Purchase Enhanced Membership today to remove them!
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.