Jump to content
Forums Gone... but not forgotten!
Pontiac of the Month

DrDave's 1970 Trans Am

2018 May
of the Month

  • Welcome to Forever Pontiac

    Welcome to Forever Pontiac, full of great ideas for Pontiac performance, maintenance, or for peer-to-peer assistance from Professional and DIY mechanics. Also, compete in our Pontiac monthly competitions. Please register if you'd like to take part.

Recommended Posts

Hello, our 16 year old found a 1980 Phoenix that had less than 80k miles on it for less than a grand so she bought it. After a water pump, pads, calipers and rotors we still cant get the drivers side caliper to retract.

The passenger side is fine.  When the car is on stands and in drive the rotors are turning true, no wobbling, which is hopefully telling me the hub is running straight.

When the brakes are applied the drivers side caliper, which is brand-new, wont retract back unless I open the bleeder valve. When I open the bleeder valve the caliper retracts and the wheel hub starts spinning normally.

Can anyone please give me some insight on what the problem may be? The caliper is getting plenty of fluid on the bleed but just isn't retracting. 

Thank you,
Dana

Share this post


Link to post
Share on other sites

Tired of these Ads? Register Today!

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Featured Topics

  • Similar Content

    • By Kenny556
      Hey I’m new here, looking for front rotors on my Catalina. It came factory with disk front and will eventually need rotors for it and can’t find any anywhere. Down the road I want to upgrade the suspension but can’t find anything there either. Ultimately I want it to be a fun boat to cruise in with some power I can take down the strip occasionally
    • By Grand am man
      I have a 2000 pontiac grand am 3.4 liter i recently changed my front breaks and i understand new pads smell a little but i drove it on the freeway and at one point i had to push break pedal all ths down to stop what did i do wrong? Also it kind of overheats temp goes 3 notches above normal temp but never fully overheats once i start moving it cools down just want to fix small issue before it gets worse any advice would be great. One more where are the other spark plugs only 3 are visible in front and how do i get to them?
Tired of these Ads? Purchase Enhanced Membership today to remove them!
×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.