Jump to content
Forums Gone... but not forgotten!

Ramairgt2

Members
  • Content Count

    127
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Ramairgt2

  • Rank
    Century Club
  • Birthday 02/02/1982

Profile Information

  • Location
    Wisconsin
  • Interests
    Ask me and I'll tell you my interests...

Forever Pontiac

  • Year
    97
  • Car
    Grand Prix
  • Trim
    SE
  • Engine
    3800 N/A
  • Style
    Sedan
  • Color
    Red
  1. Well guys its been a long time.... A lot has changed. I was in a bad accident and totaled out my explorer in January this year. My son and I are both fine although I am still continuing chiropractic sessions once a week... So I was forced to bring my GTP out. I've since installed a brand new crate engine direct from the GM plant in detroit. Its a brand new L67 with the black valve covers,aluminum oil pan etc etc. Anyways here's some pics from today. I've also got an SD hood on it now.
  2. Hey everyone I just wanted to share my new tattoo that I got done on Saturday night. Its in memory of my dad who I lost 9 years ago June 19th. His birthday is July 4th. I had a completely different idea in mind for the tattoo but my artist sat down with me and we came up with this one. Its a complete one off so no one else has it at this time. I'll be sure to post up a new pic of it in a week or so once its heeled so that you can see the true colors pop out.
  3. I went out to the local yard today in search of tail lights and since I didn't see any that weren't scratched up or broken, I came home with this instead.... A lund bug/stone deflector for 5 bucks..
  4. btw I learned a cool trick from a friend of mine.... my head lights were starting to haze etc.... Instead of spending 10 bucks on a restore kit I was told to use tooth paste and some elbow grease... Sure enough after buying a 99 cent tube of whitening tooth paste with the gritty stuff in it and combining some meguiars plastx that I already had, and some microfiber clothes it worked the same if not better than a headlight restore kit. I finished the headlights off with a nice coat of wax and they look pretty good.
  5. Well its obviously been quite a while since I updated this... Truck is running strong.. Since I've owned it I hadn't done too much beside routine maintenance and having the intake gaskets etc replaced. Today I washed it and cleaned the inside out really well. I've been noticing my rims looking poorer and poorer due to age and peeling and since completely redoing the rims is out of the question.... I used my black rim paint and gave them a nice paint job so let me know what you think.
  6. it very well could be. There has been absolutely zero knock anyplace or sounds of shit pinging in the motor.... I won't know for sure til I pull the rear head,,,, I'm leaving the other side alone since all is good there.
  7. On June 11th I came outside to start my car and head to work.... My car started misfiring extremely bad. It ran fine Sunday night... Anyways I left my car sit in the garage and drove the truck to work. After work a friend and I checked the codes and came back with a PO 300 code (multiple random misfires) Checked all the ignition related stuff etc and all was good. Even replaced the ICM, and Coils for shits and giggles... No changes... Plugs were not fouled out,wires are fine etc (the wires and plugs have less than 500 miles on them)... Needless to say I got pissed off and left the car sit agai
  8. Yep its running fine. The blower is ported and has the H bar removed but they are fine to run on a stock LIM.
  9. BTW please excuse the mess in my garage..... I've been super busy and haven't been able to clean or put stuff away
  10. Well since I haven't updated you guys...... I ended up pulling my motor apart twice since it was put in.... Basically the guy who put the motor together had the LIM cut out for a stage 3 IC and since I didn't go IC he put the blower on top of that LIM which caused me serious vacuum issues leading to an internal vacuum leak that could have blown my engine.... I had so much suction at idle that I could literally put my hand over the valve cap hole and stall the car out... Under boost it caused the dipstick to blow out of the tube(didn't find this stuff out right away until myself and a friend w
  11. I should also note that the old engine was out by 11 a.m. yesterday and the new one was in by 4 p.m. We had the car running at 10 last night .
  12. Old L67 New L32 being prepped and last minute recheck of the front cover... Engine bay was relatively clean(I didn't get any pics of it but I did clean the trans and engine bay) Engine installed and my friend Gabe working on the harness... I owe a big thanks to him for letting me use his garage and lending a hand. Thats it for now. Let me know what you guys think. I've also got a quick video I'm trying to upload.
  13. Oh and I'm getting a nice wicked tune next week......
Tired of these Ads? Purchase Enhanced Membership today to remove them!
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.